MOUNTAIN (B) - CitC (Coding in the Cloud) PRODUCTION upgrade to 26.8.10.0 (R26 JUL SP2 - August Feature Release)

Scheduled for Sep 9, 00:00 - 02:00 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 08, 2026 - 07:35 CDT

Scheduled

This maintenance window is cancelled.

Please see the following KB for additional information:
https://solventumhis.servicenowservices.com/kb_view.do?sysparm_article=KB0014100

PRODUCTION environments will be NOT upgraded to 26.8.10.0 (R26 JUL SP2 - August Feature Release)
Posted Aug 06, 2026 - 13:37 CDT
This scheduled maintenance affects: US Mountain (PRODUCTION - Coding in the cloud (CITC)).