Production updates to 25.5.10.0 are taking significantly longer than expected

Resolved

Scheduled feature release updates have been completed. In situations where the window overran the window by an hour or more, service owners have created Service Now tickets to document the unplanned downtime.
Posted Jun 12, 2025 - 08:51 CDT

Monitoring

Tonight's scheduled production update of managed 360 Encompass in the cloud environments is taking significantly longer than expected in almost all cases.

Contact your application administrator if you have specific questions or would like to know your system's ETA.
Posted Jun 11, 2025 - 20:03 CDT
This incident affected: US Central (PRODUCTION (A) - 360 Encompass, PRODUCTION (B) - 360 Encompass), US Pacific (PRODUCTION (A) - 360 Encompass, PRODUCTION (B) - 360 Encompass), US Mountain (PRODUCTION (A) - 360 Encompass, PRODUCTION (B) - 360 Encompass), and US East (PRODUCTION (A) - 360 Encompass, PRODUCTION (B) - 360 Encompass).