Completed
The scheduled maintenance has been completed.
Posted May 17, 2025 - 03:00 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 16, 2025 - 23:00 CDT
Scheduled
General Solventum network maintenance will occur between 00:00 and 04:00 EDT on 2025-05-17.
The maintenance is not expected to affect end-users directly but touches upon network egress and may temporarily impact the correct functioning of some application services (e.g. auto-suggested, Edit Engine, etc.).
Please report issues using the Solventum support website, https://solventumhis.servicenowservices.com/
Posted May 16, 2025 - 17:02 CDT
This scheduled maintenance affected: 3M Community Cloud Services (Outpatient NLP, Inpatient NLP, OCR, Edit Engine, SSR, WSS), US Central (PRODUCTION (A) - 360 Encompass, PRODUCTION - Coding and Reimbursement System (CRS) legacy, Non-production (A) - 360 Encompass, Non-production - Coding and Reimbursement System (CRS) legacy, PRODUCTION - Coding in the cloud (CITC), Non-production - Coding in the cloud (CITC), PRODUCTION (B) - 360 Encompass, Non-production (B) - 360 Encompass), US Pacific (PRODUCTION (A) - 360 Encompass, PRODUCTION - Coding and Reimbursement System (CRS) legacy, Non-production (A) - 360 Encompass, Non-production - Coding and Reimbursement System (CRS) legacy, PRODUCTION - Coding in the cloud (CITC), Non-production - Coding in the cloud (CITC), PRODUCTION (B) - 360 Encompass, Non-production (B) - 360 Encompass), US East (Non-production - Coding and Reimbursement System (CRS) legacy, PRODUCTION - Coding and Reimbursement System (CRS) legacy, Non-production (A) - 360 Encompass, PRODUCTION (A) - 360 Encompass, PRODUCTION - Coding in the cloud (CITC), Non-production - Coding in the cloud (CITC), Non-production (B) - 360 Encompass, PRODUCTION (B) - 360 Encompass), US Mountain (PRODUCTION (A) - 360 Encompass, PRODUCTION - Coding and Reimbursement System (CRS) legacy, Non-production (A) - 360 Encompass, Non-production - Coding and Reimbursement System (CRS) legacy, PRODUCTION - Coding in the cloud (CITC), Non-production - Coding in the cloud (CITC), Non-production (B) - 360 Encompass, PRODUCTION (B) - 360 Encompass), and Asia Pacific (PRODUCTION - 360 Encompass in the cloud, Non-production - 360 Encompass in the cloud).