360 Encompass version 25.8.20.1

Resolved

25.8.30.0 is being applied to production environments; 25.8.20.1 is superseded.
Posted Oct 15, 2025 - 21:04 CDT

Monitoring

On Friday, 2025-10-03, Solventum released 360 Encompass version 25.8.20.1.

The release is significant in scope, takes approximately 90-120 minutes to apply and includes some regulatory content and resolves a specific KB (KB0013070).

360 Encompass code updates are cumulative and the 25.8.30.0 release, which will be available beginning on Thursday, 2025-10-09, includes that content.

For managed customer deployments, the 25.8.30.0 release will be applied to production systems on Wednesday, 2025-10-15.

Solventum Managed Services Operations (MSO) only be applying the 25.8.20.1 release on demand. To request application of this release, please create a Service Now ticket (at https://solventumhis.servicenowservices.com/).
Posted Oct 06, 2025 - 09:13 CDT
This incident affected: US Central (PRODUCTION (A) - 360 Encompass, PRODUCTION - Coding in the cloud (CITC), PRODUCTION (B) - 360 Encompass), US Pacific (PRODUCTION (A) - 360 Encompass, PRODUCTION - Coding in the cloud (CITC), PRODUCTION (B) - 360 Encompass), US Mountain (PRODUCTION (A) - 360 Encompass, PRODUCTION - Coding in the cloud (CITC), PRODUCTION (B) - 360 Encompass), and US East (PRODUCTION (A) - 360 Encompass, PRODUCTION - Coding in the cloud (CITC), PRODUCTION (B) - 360 Encompass).