2026-01-07 - 360Eitc B block Central time: erroneous email about incorrect start time for 25.11.20.0

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 18:46 CST

Monitoring

Due to an administrative error, this website transmitted a notification that the scheduled update for 25.11.20.0 would begin for deployments whose production maintenance window is in the B group Central time.

This is not the case. The maintenance will begin at its normal time of 23:00 Central.

The notice has been corrected, but email notices will have been sent to subscribers.

We regret any inconvenience.
Posted Jan 07, 2026 - 12:24 CST
This incident affected: US Central (PRODUCTION (B) - 360 Encompass, Non-production (B) - 360 Encompass).