Production maintenance task has completed for deployments in production support for https://pe5.citc.solventum.com Status will change from Monitoring to Resolved on June 5, 2026 at 09:00 (Eastern).
Posted Jun 04, 2026 - 21:04 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 04, 2026 - 11:44 CDT
Investigating
To help prevent unexpected outages for CitC sites hosted at https://pe5.citc.solventum.com, Managed Services Operations will perform maintenance this evening starting at 9:00 PM Eastern. During this time, AWS will be applying automated infrastructure updates. To minimize the risk of service interruption, CitC services at https://pe5.citc.solventum.com will be proactively managed. The maintenance is expected to last approximately 1 hour. Thank you for your understanding.
Posted Jun 04, 2026 - 11:43 CDT
This incident affected: US East (PRODUCTION - Coding in the cloud (CITC)), US Central (PRODUCTION - Coding in the cloud (CITC)), US Mountain (PRODUCTION - Coding in the cloud (CITC)), and US Pacific (PRODUCTION - Coding in the cloud (CITC)).