Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 02, 2026 - 04:00 CDT
Scheduled
On September 2, 2026, between 05:00 and 08:00 Eastern Time, a production maintenance will be performed to migrate parallel customer workloads from 3mhis.com to solventum.com Coding in the Cloud (CitC) deployments. This migration supports the ongoing transition to the Solventum platform branding and will help provide a consistent customer experience across CitC environments.
During this maintenance period, users may experience a brief service interruption lasting less than five minutes and could encounter messages such as “502 Gateway Error” or “CRS session ended unexpectedly.”
This maintenance does not impact customers currently using Coding in the Cloud deployments with URLs containing Solventum.com.
Posted Sep 01, 2026 - 10:30 CDT
This scheduled maintenance affected: US East (PRODUCTION - Coding in the cloud (CITC)), US Central (PRODUCTION - Coding in the cloud (CITC)), US Mountain (PRODUCTION - Coding in the cloud (CITC)), and US Pacific (PRODUCTION - Coding in the cloud (CITC)).