> At 12:26 AM on October 20, we identified the trigger of the event as DNS resolution issues for the regional DynamoDB service endpoints...resulting in network connectivity issues in multiple services such as Lambda, DynamoDB, and CloudWatch.
According to AWS, residual latency/slowness was caused by "services [that] continue to have a backlog of messages that they will finish processing over the next few hours."
Please contact your Service Owner or Solventum support for additional details related to impact and/or RCA.
Posted Oct 21, 2025 - 09:15 CDT
Update
The latest AWS update confirms that the issue is generally resolved.
A very small number of Solventum-managed deployments continue to experience lingering effects from the outage, but none directly related AWS services currently in a failed/degraded state.
This incident record (on status.3mhis.com) will remain open and in "Monitoring" status through the night and into tomorrow.
Beginning now, it will only be updated when new information becomes available or, e.g. if issues re-emerge.
Posted Oct 20, 2025 - 16:33 CDT
Update
AWS reports that "[s]ervice recovery across all AWS services continues to improve."
At this time, a small number of end-users continue to experience network disconnections and latency issues. In some cases, due to apparently lingering effects from network drops and disconnections experienced earlier in the day.
Since services appear to be mostly recovered, end-users who continue to be affected by apparent network issues should contact their assigned Service Owner or Solventum Support with specific details.
Posted Oct 20, 2025 - 15:21 CDT
Update
The most recent AWS update says that some services are recovering, but that there will still be "work to address residual network connectivity issues."
At present, most end-users will be able to access managed deployments, but for some end-users, network performance may be poor (e.g. slow) or subject to intermittent failures, e.g. dropped encoder sessions.
Common indications of dropped or disconnected sessions are:
- CRS/Codefinder shows the error: "Warning: session may have timed out or had an error occur." - 360 Encompass CAC shows the error: "The server was unable to retrieve the requested data" - WinAppLink updates may fail to download: "Unable to download file from the sever" - Integrated session interface tester shows the error: "Unable to create web socket"
Posted Oct 20, 2025 - 14:42 CDT
Update
The latest updated from AWS confirms that general resolution of the issue is not far off.
Some sites may still be affected.
Posted Oct 20, 2025 - 13:39 CDT
Update
AWS services are still affected and some end-users report network failures preventing them from accessing managed deployments of 360 Encopmass in the cloud.
AWS has not announced a general resolution or recovery at this time.
Posted Oct 20, 2025 - 13:19 CDT
Update
The latest updated from AWS states that they expect full resolution shortly.
At the same time, end-users have begun to report that DNS and networking issues appear to be resolving.
Solventum MSO continues to monitor issues affecting managed deployments.
Posted Oct 20, 2025 - 12:48 CDT
Update
AWS is continuing to mitigate the issue but has not yet announced a root cause or the resolution of the root cause.
Currently, private/hosted DNS resolution remains in a totally failed state: for 360Eitc deployments where Solventum hosts DNS records, this will mean that end-users are unable to access the Solventum-managed deployment.
Public, Internet-facing DNS resolution appears unaffected. Internet-facing deployments, such as CRS in the cloud (CITC) are working as expected. The details of this incident have been updated to reflect that.
Posted Oct 20, 2025 - 12:04 CDT
Update
Disruptive services failures (primarily DNS resolution) continue to affect Solventum-managed deployments (see previous update).
Not all deployments are affected and not all affected deployments are affected equally.
The next scheduled update from AWS is scheduled for 13:00 Eastern US time. This incident will be updated at that point.
Posted Oct 20, 2025 - 11:39 CDT
Update
The AWS degradation appears to have increased in scope and severity. DNS resolution is now generally affected.
Symptoms include:
- orange browser error screens containing the text "ERR_NAME_NOT_RESOLVED" - integrated session launch errors, e.g. "Failed to execute 'send' on 'XMLHttpRequest" or "Unable to create web socket"
Posted Oct 20, 2025 - 11:20 CDT
Update
AWS has updated their Service Health page to indicate that "significant API errors and connectivity issues" are now occurring.
The full scope of these "significant" issues is unknown, but network effects may prevent end-users from accessing Solventum-managed applications and subscriptions.
Posted Oct 20, 2025 - 09:46 CDT
Monitoring
Starting around midnight Eastern, AWS confirmed that various issues are affecting critical managed services in the flagship US-EAST-1 region.
Some of the affected services are used by 360Eitc and CITC deployments managed by Solventum.
The Solventum MSO team is monitoring and spot-checking and is prepared to respond to incidents that affect customer deployments.
Please contact Solventum Service Owners or Support with questions about specific applications/subscriptions/deployments.
Posted Oct 20, 2025 - 09:15 CDT
This incident affected: US Central (PRODUCTION (A) - 360 Encompass, Non-production (A) - 360 Encompass, PRODUCTION - Coding in the cloud (CITC), Non-production - Coding in the cloud (CITC), PRODUCTION (B) - 360 Encompass, Non-production (B) - 360 Encompass), US Pacific (PRODUCTION (A) - 360 Encompass, Non-production (A) - 360 Encompass, PRODUCTION - Coding in the cloud (CITC), Non-production - Coding in the cloud (CITC), PRODUCTION (B) - 360 Encompass, Non-production (B) - 360 Encompass), US Mountain (PRODUCTION (A) - 360 Encompass, Non-production (A) - 360 Encompass, PRODUCTION - Coding in the cloud (CITC), Non-production - Coding in the cloud (CITC), Non-production (B) - 360 Encompass, PRODUCTION (B) - 360 Encompass), and US East (Non-production (A) - 360 Encompass, PRODUCTION (A) - 360 Encompass, PRODUCTION - Coding in the cloud (CITC), Non-production - Coding in the cloud (CITC), Non-production (B) - 360 Encompass, PRODUCTION (B) - 360 Encompass).