25.11.10.0 updates to non-production systems will be delayed

Monitoring

Scheduled non-production maintenance for 2025-12-04 has been rescheduled for the following week.

Please subscribe to KB0013198 for additional updates about the repost of the 25.11.10.0 release.

https://solventumhis.servicenowservices.com/kb/en/solventum-has-taken-down-360-encompass-v25-11-10-0?id=kb_article_view&sysparm_article=KB0013198
Posted Dec 03, 2025 - 20:45 CST

Update

Please subscribe to KB0013198 for additional updates about the repost of the 25.11.10.0 release.

https://solventumhis.servicenowservices.com/kb/en/solventum-has-taken-down-360-encompass-v25-11-10-0?id=kb_article_view&sysparm_article=KB0013198
Posted Dec 03, 2025 - 15:17 CST

Identified

Later today, scheduled 360Eitc updates to 25.11.10.0 in non-production environments will be rescheduled.

Details about when and why will be published shortly.
Posted Dec 03, 2025 - 13:28 CST
This incident affects: US Central (Non-production (A) - 360 Encompass, PRODUCTION (B) - 360 Encompass), US Pacific (Non-production (A) - 360 Encompass, Non-production (B) - 360 Encompass, Non-production (C) - 360 Encompass), US Mountain (Non-production (A) - 360 Encompass, Non-production (B) - 360 Encompass), and US East (PRODUCTION (A) - 360 Encompass, Non-production (B) - 360 Encompass, Non-production (C) - 360 Encompass).