MOUNTAIN (A) - production upgrade to 25.8.10.0 (R25 JUL SP2)

Scheduled for Sep 10, 19:00 - 22:00 CDT

Update

Production environments will be upgraded to 25.8.10.0 (R25 JUL SP2) of the 3M™ 360 Encompass™ System.

This includes 360 Encompass in the cloud systems that belong to the A group.
Posted Aug 27, 2025 - 20:20 CDT

Update

Production environments will be upgraded to 25.8.10.0 (R25 JUL SP2) of the 3M™ 360 Encompass™ System.

This includes 360 Encompass in the cloud systems that belong to the A group.
Posted Aug 27, 2025 - 20:18 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 27, 2025 - 20:17 CDT

Scheduled

Production environments will be upgraded to 25.8.10.0 (R25 JUL SP2) of the 360 Encompass System.

This includes 360 Encompass in the cloud systems that belong to the A group.
Posted Aug 06, 2025 - 18:36 CDT
This scheduled maintenance affects: US Mountain (PRODUCTION (A) - 360 Encompass, PRODUCTION - Coding in the cloud (CITC)).