Scheduled CRS/Codefinder/CITC update to 25.2.20.0 (R25 APR GEN) is postponed

Monitoring

CITC (CRS/Coding in the cloud) systems will be updated to 25.2.20.0 the evening of Wednesday, 2025-04-09, starting at 23:00 EDT.

Legacy CRS systems WILL NOT BE UPDATED to 25.2.20.0, unless by request. Please create a request on https://solventumhis.servicenowservices.com/
Posted Apr 03, 2025 - 10:53 CDT

Update

The Solventum Web Experience team has applied a fix for this issue; MSO is testing it now.
Posted Apr 03, 2025 - 10:11 CDT

Update

Once the issue affecting the Support site is resolved, this update will be rescheduled

When that happens, this incident will be updated with specific details about the reschedule date.
Posted Apr 02, 2025 - 21:27 CDT

Identified

The ongoing migration to the new Support website (https://solventumhis.servicenowservices.com/) has had the unintended side effect of preventing the CRS Updater application from validating auth keys. This prevents CRS updates from being applied.

This DOES NOT affect 360 Encompass in the cloud.

This does affect all CRS/Codefinder/CITC deployment.

Scheduled maintenance for CRS deployments is postponed and may be rescheduled.
Posted Apr 02, 2025 - 18:10 CDT
This incident affects: US Central (PRODUCTION - Coding and Reimbursement System (CRS) legacy, PRODUCTION - Coding in the cloud (CITC)), US Pacific (PRODUCTION - Coding and Reimbursement System (CRS) legacy, PRODUCTION - Coding in the cloud (CITC)), US East (PRODUCTION - Coding and Reimbursement System (CRS) legacy, PRODUCTION - Coding in the cloud (CITC)), and US Mountain (PRODUCTION - Coding and Reimbursement System (CRS) legacy, PRODUCTION - Coding in the cloud (CITC)).